Configuring FlexFabric 5900 Management switch

Prerequisites

Retrieve the following parameters of the FlexFabric 5900 switch from the input JSON file:

  • Name of the switch

  • Password of the default administrator user

  • VLAN ID of the iLO-OOBM network

  • Configure iLO-OOBM gateway in the customer core switch

  • iLO OOBM IP address and iLO-OOBM netmask

Procedure
  1. Connect the switch to the computer using the console cable that is provided with the switch, and power on the switch.

    For more information about using the switch, see Powering on the switch for the first time in the HPE FlexFabric 5900 Switch Series Installation Guide here;

    http://h17007.www1.hpe.com/device_help/H3C-Manuals/5900/5900-Installation-Guide(20111231).pdf
  2. At the switch prompt run the following commands:
    NOTE:

    Ensure to replace the sample data in the following configuration with the valid data from the Input JSON file.

    sysname <name of switch>
    # netconf ssh server enable 
    ssh server enable 
    #
    local-user admin class manage 
    password simple <Password of default administrator user>
    authorization-attribute user-role network-admin 
    service-type ssh 
    quit 
    #
    user-interface vty 0 63 
    authentication-mode scheme 
    protocol inbound ssh 
    quit
    #
    vlan <VLAN ID of iLO-OOBM network> 
    Name ILO-OOBM
    ip address <ILO_OOBM IP> <netmask>
    #
    interface Bridge-Aggregation50
    description <as per Port map>
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 2 to 4094 
    port trunk pvid vlan <VLAN ID of iLO-OOBM network>
    link-aggregation mode dynamic
    #
    interface GigabitEthernet1/0/1
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/2
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/3
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/4
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/5
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/6
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/7
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/8
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/9
    port link-mode bridge
    description <as per Port map>
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/47
    description SN2100M-1 eth0  interface connectivity
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface GigabitEthernet1/0/48  
    description SN2100M-2 eth0  interface connectivity
    port access vlan <VLAN ID of iLO-OOBM network>
    #
    interface  Ten-GigabitEthernet1/0/49
    description Frame-1-Bottom_FLM
    port access vlan <ilo>
    #
    interface  Ten-GigabitEthernet1/0/50
    description Frame-2-Top_FLM
    port access vlan <ilo>
    #
    interface Ten-GigabitEthernet1/0/51
    description <as per Port map>
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 2 to 4094 
    port trunk pvid vlan <VLAN ID of iLO-OOBM network>
    port link-aggregation group 50
    #
    interface Ten-GigabitEthernet1/0/52
    port link-mode bridge
    description <as per Port map>
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan 2 to 4094 
    port trunk pvid vlan <VLAN ID of iLO-OOBM network>
    port link-aggregation group 50 
    #
    interface M-GigabitEthernet0/0/0
    description <as per Port map>
    ip address <iLO-OOBM IP address> <iLO-OOBM netmask>