Manually configuring HPE FlexFabric 5950 (Data) switches

Both the FlexFabric 5950 switches are connected as a highly available active-active fabric.

Prerequisites

Ensure that the IRF(Intelligent Resilient Framework) is configured for HPE FlexFabric 5950 data switch. For more information on IRF configuration, see HPE FlexFabric 5950 Switch Series IRF Configuration Guide.

Procedure
  1. Retrieve the following parameters for each of the HPE FlexFabric 5950 switches from the Input JSON file:
    • Name of the switch

    • Password of the default administrator user

    • Initial temporary configuration IP address (initial_temp_config_ip) and VIM-PXE netmask

    NOTE:
    • As per the Port map, the Management NIC (Port 1) of the NPS toolkit host is connected to the TenGigE 1/0/11:1.

    • As per the Port map, the Management NIC (Port 2) of the NPS toolkit host is connected to the HundredGigE 2/0/11:1
  2. Connect the console of the first HPE FlexFabric 5950 switch (switch-1) to the computer using the console cable that is provided with the switch, and power on the switch.

    For more information about using the switch, see Accessing the switch for the first time in the HPE FlexFabric 5950 Switch Series Installation Guide.

  3. To split the interface port of the HPE FlexFabric 5950 into four ports, each of value 10G, run the following commands from the console of the HPE FlexFabric 5950:
    For the first NIC, run the following command:
    [5950] interface HundredGigE 1/0/11
    [5950-HundredGigE1/0/11]using tengige
    The interface HundredGigE1/0/11 will be deleted. Continue? [Y/N]:y
    For the second NIC, run the following command:
    [5950] interface HundredGigE 2/0/11
    [5950-HundredGigE2/0/11]using tengige
    The interface HundredGigE2/0/11 will be deleted. Continue? [Y/N]:y
  4. To access the NPS toolkit host and deploy the following configurations, run the corresponding commands on the FlexFabric 5950 switch:
    vlan <VIM-PXE VLAN ID>
    vlan <transport VLAN ID>
    interface Vlan-interface<VIM-PXE VLAN ID>
    description VIM-PXE network
    ip address <vim-pxe-gw> <subnet_mask>
    #
    interface Vlan-interface<VLAN ID>
    <This VLAN interface is used to establish the communication
    between the customer infra switch and the data TOR switch HPE
    FlexFabric 5950)
    ip address <transport NW IP > <mask >
    #
    interface HundredGigE1/0/1
    port link-mode bridge
    description Uplink to customer network
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan <VIM-PXE VLAN ID> <transport VLAN ID>
    port trunk pvid vlan <transport VLAN ID>
    interface Ten-GigabitEthernet1/0/11:1
    port link-mode bridge
    description DL NPS toolkit host FLR1
    port link-type trunk
    undo port trunk permit vlan 1
    port trunk permit vlan VIM-PXE VLAN ID>
    port trunk pvid vlan <VIM-PXE VLAN ID>
    ip route-static 0.0.0.0 0 <next hop transport IP address>
  5. At the switch prompt, run the following commands.
    NOTE:

    Ensure replacement of the sample data in the following configuration with the valid data from the Input JSON file.

    sysname <name of system>
    interface vlan 1
    ip address <initial_temp_config_ip> <vim-pxe netmask>       
    
    netconf ssh server enable
    ssh server enable
    scp server enable 
    
    local-user admin class manage
    password simple <Password of default administrator user>
    authorization-attribute user-role network-admin
    service-type ssh
    service-type ftp
    quit
    
    user-interface vty 0 63
    authentication-mode scheme
    protocol inbound ssh
    quit