Manually configuring data switch for the starter and expansion kits

The manual data switch (Comware only) configuration process for the starter and expansion kits is as follows:
  1. Configuration of service loopback group of the VSI gateway type

  2. Reserve VLAN configuration

  3. VSI configuration

  4. VSI interface configuration

  5. VxLAN configuration

  6. Uplink configuration for peer switches (Customer Infra Switch)

  7. Port configuration for server.

Following is a sample Configuration example for the overlay network or Blueprint control plane network.

This configuration is applicable to the Starter and Compute expansion kits. The Controller Node configuration and Storage port configuration are not applicable for Compute Expansion kit as the compute expansion has only the compute node.

Procedure
  1. Create VSI gateway service loopback group 1, and assign Layer 2 Ethernet interface HundredGigE 1/0/29 and HundredGigE 2/0/29 to the service loopback group.
    service-loopback group 1 type vsi-gateway
    interface  hundredgige 1/0/29
    port service-loopback group 1
    All configurations on the interface will be lost. Continue?[Y/N]:y
    
    interface  hundredgige 2/0/29
    port service-loopback group 1
    All configurations on the interface will be lost. Continue?[Y/N]:y
    
  2. Reserve the global VLAN interface resource of VLAN 4081 to 4094.
    reserve-vlan-interface 4081 to 4094 global
  3. VSI and VxLAN configuration.
    vsi 160
     description PXE
     gateway vsi-interface 160
     gateway subnet 10.206.160.0 0.0.0.255
     arp suppression enable
     vxlan 16000
    #
    vsi 161
     description CLM
     gateway vsi-interface 161
     gateway subnet 10.206.161.0 0.0.0.255
     arp suppression enable
     vxlan 16100
    #
    vsi 162
     description BLS
     gateway vsi-interface 162
     gateway subnet 10.206.162.0 0.0.0.255
     arp suppression enable
     vxlan 1620
    
  4. VSI Interface Configuration.
    interface Vsi-interface160
     description PXE
     ip address 10.206.160.1 255.255.255.0  
     distributed-gateway local
    #
    interface Vsi-interface161
     description CLM
     ip address 10.206.161.1 255.255.255.0  
     distributed-gateway local
    #
    interface Vsi-interface162
     description BLS
     ip address 10.206.162.1 255.255.255.0 
     distributed-gateway local
    
  5. Uplink configuration for Synergy F8 Virtual Connect with HPE FlexFabric 5950 data switch.
    Virtual connect ports Q1, Q2, and Q3 are connected to HPE FlexFabric 5950 switch and configured as a dynamic bridge aggregation; the following is an example for one VC. In one enclosure two virtual connects are available.
    interface Bridge-Aggregation8
     description BAGG-Frame1-ICM3-Q1-Q3
     port link-type trunk
     undo port trunk permit vlan 1 
     link-aggregation mode dynamic
     service-instance 160
       encapsulation untagged
      xconnect vsi 160 access-mode ethernet
     service-instance 161
      encapsulation s-vid 161
      xconnect vsi 161
     service-instance 162
      encapsulation s-vid 162
      xconnect vsi 162
    
    
    interface HundredGigE1/0/13
     description Frame-1-ICM-3-Q1
     port link-type trunk
     undo port trunk permit vlan 1  
     lacp period short
     lacp mode passive
     port link-aggregation group 8
    #
    interface HundredGigE2/0/13
     description Frame-1-ICM-3-Q2
     port link-type trunk
     undo port trunk permit vlan 1  
     lacp period short
     lacp mode passive
     port link-aggregation group 8
    
  6. Uplink configuration for SH2200 (for compute node):
    For compute node connectivity, SH2200 are used and the uplink (per switch 6 uplink) is connected to HPE FlexFabric 5950 switch. Following is an example for only one SH2200.
    interface Bridge-Aggregation10
     description Frame1-ICM2-Q1-Q6 and ICM5-Q1-Q6
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     link-aggregation mode dynamic
    
     interface HundredGigE1/0/16
     port link-mode bridge
     description Frame-1-ICM-2-Q1
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/16
     port link-mode bridge
     description Frame-1-ICM-2-Q2
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE1/0/17
     port link-mode bridge
     description Frame-1-ICM-2-Q3
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/17
     port link-mode bridge
     description Frame-1-ICM-2-Q4
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE1/0/18
     port link-mode bridge
     description Frame-1-ICM-2-Q5
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/18
     port link-mode bridge
     description Frame-1-ICM-2-Q6
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    
    interface HundredGigE1/0/19
     port link-mode bridge
     description Frame-1-ICM-5-Q1
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/19
     port link-mode bridge
     description Frame-1-ICM-5-Q2
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE1/0/20
     port link-mode bridge
     description Frame-1-ICM-5-Q3
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/20
     port link-mode bridge
     description Frame-1-ICM-5-Q4
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE1/0/21
     port link-mode bridge
     description Frame-1-ICM-5-Q5
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    interface HundredGigE2/0/21
     port link-mode bridge
     description Frame-1-ICM-5-Q6
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan  801 to 900
     port link-aggregation group 10
    #
    
  7. Switch Port configuration for Controller Node:
    IMPORTANT:

    This configuration is applicable only to the starter kit

    1. NPS Node configuration (tagged and untagged).
      interface Bridge-Aggregation1
       description BAGG-NPS-FLR
       port link-type trunk
       undo port trunk permit vlan 1
       port trunk permit vlan 163 
       link-aggregation mode dynamic
       service-instance 160
            encapsulation untagged
           xconnect vsi 160 access-mode ethernet
         service-instance 160
      
      interface Ten-GigabitEthernet1/0/11:1
       description BAGG-NPS-FLR-1
        port link-type trunk
        undo port trunk permit vlan 1
        port trunk permit vlan 163 
        link-aggregation mode dynamic
         port link-aggregation group 1
      #
      interface Ten-GigabitEthernet2/0/11:1
       description BAGG-NPS-FLR-2
        port link-type trunk
        undo port trunk permit vlan 1
        port trunk permit vlan 163 
        link-aggregation mode dynamic
        port link-aggregation group 1
      
    2. VIM Controller Configuration for management Interface and data Interface (PCI).
      interface Bridge-Aggregation2
       description BAGG-RH-VIM-Ctrl1-FLR
       port link-type trunk
       undo port trunk permit vlan 1
       port trunk permit vlan 164 
       link-aggregation mode dynamic
       service-instance 160
            encapsulation untagged
           xconnect vsi 160 access-mode ethernet
          service-instance 161
           encapsulation s-vid 161
           xconnect vsi 161
          service-instance 162
           encapsulation s-vid 162
        xconnect vsi 162
      
      interface Ten-GigabitEthernet1/0/11:2
       description BAGG-RH-VIM-Ctrl1-FLR-1
        port link-type trunk
        undo port trunk permit vlan 1
        port trunk permit vlan 164 
        link-aggregation mode dynamic
       lacp period short
       lacp mode passive
        port link-aggregation group 2
      # 
      interface Ten-GigabitEthernet2/0/11:2
       description BAGG-RH-VIM-Ctrl1-FLR-2
        port link-type trunk
        undo port trunk permit vlan 1
        port trunk permit vlan 164 
        link-aggregation mode dynamic
        lacp period short
        lacp mode passive
        port link-aggregation group 2
       #
      
    3. PCI configuration for VIM controller 1. Similar configuration steps are applicable to controllers 2 and 3.
      interface Bridge-Aggregation5
       description BAGG-RH-VIM-Ctrl1-PCI
       port link-type trunk
        undo port trunk permit vlan 1
        port trunk permit vlan  801 to 900
       link-aggregation mode dynamic
      
      interface Ten-GigabitEthernet1/0/12:1
       description BAGG-RH-VIM-Ctrl1-PCI1.1
        port link-type trunk
         undo port trunk permit vlan 1
         port trunk permit vlan  801 to 900
       link-aggregation mode dynamic
       port link-aggregation group 5
      #
      
      interface Ten-GigabitEthernet2/0/12:1
       description BAGG-RH-VIM-Ctrl1-PCI1.2
        port link-type trunk
         undo port trunk permit vlan 1
         port trunk permit vlan  801 to 900
       link-aggregation mode dynamic
       port link-aggregation group 5
      
    4. HPE 3PAR storage port configuration:
      IMPORTANT:

      BLS network must be untagged for this step.

      interface Ten-GigabitEthernet1/0/28:1
      desc 3PAR Node0 PORT 1 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet2/0/28:1
      desc 3PAR Node0 PORT 2 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet1/0/28:2
      desc 3PAR Node1 PORT 1 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet2/0/28:2
      desc 3PAR Node1 PORT 2 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode Ethernet
      
      interface Ten-GigabitEthernet1/0/28:3
      desc 3PAR Node2 PORT 1 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet2/0/28:3
      desc 3PAR Node2 PORT 2
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet1/0/28:4
      desc 3PAR Node3 PORT 1 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
      interface Ten-GigabitEthernet2/0/28:4
      desc 3PAR Node3 PORT 2 
      service-instance 162
           encapsulation untagged
           xconnect vsi 162 access-mode ethernet
      
  8. Compute node configuration for both SH2200:
    NOTE:

    This configuration is applicable to both the starter kit and expansion compute.

    1. Configure the following on both switches for dpdk deployment:
      mx01 (config) # interface mlag-port-channel 10
      mx01 (config interface port-channel 10 ) # exit
      
    2. To set the MLAG interface in LACP mode, run the following command:
      mx01 (config) # interface ethernet 1/9 mlag-channel-group 10 mode active
    3. Enable interfaces.
      mx01 (config) # interface mlag-port-channel 10 no shutdown 
      
      mx01 (config) # interface mlag-port-channel 10
      mx01 (config interface mlag-port-channel 10 ) # mtu 9216 force
      
  9. MLAG for Uplink to TOR HPE FlexFabric 5950 switch.
    1. Configure the following on both switches.
      mx01 (config) # interface mlag-port-channel 100
      mx01 (config interface port-channel 100 ) # exit
      
    2. Set the mode (LACP or static) – Only one option is applicable.
    3. To set the MLAG interface in LACP mode, run the following command.
      mx01 (config) # interface ethernet 1/1-1/6 mlag-channel-group 100 mode active
    4. Enable the interfaces.
      mx01 (config) # interface mlag-port-channel 100 no shutdown 
    5. VLAN configuration.
      mx01 (config) #  vlan 801-900
    6. Allowed VLAN on the configured interface port.
      interface mlag-port-channel 10 switchport mode trunk
      interface mlag-port-channel 10 switchport trunk allowed-vlan add 801-900
       
      interface mlag-port-channel 100 switchport mode trunk
      interface mlag-port-channel 100 switchport trunk allowed-vlan add 801-900
      
    7. Trunk configuration for HOST for SRIOV deployment.
      interface ethernet 1/10 switchport mode trunk
      interface ethernet 1/10 switchport trunk allowed-vlan add 801-900
      #