Establishing connectivity between starter kit and expansion kit switch with customer network switch

To establish communication between Telco Blueprint and the Customer Data Center network, Blueprint TOR must connect with the Customer Network TOR or Customer Network Data Center switch. IP configuration is required on the Blueprint TOR switch. This enables communication between Blueprint TOR and the Customer Switch based on customer-provided routing protocol.
  • Loopback configuration is required for VxLAN tunnel configuration.

  • Routing Protocol configuration is required to communicate with DC network.

Connectivity with Customer Network switch

Once the NFV Blueprint is available at customer premises, underlay network configuration or transport network configuration is performed. This enables NFV Blueprint to communicate with the customer network. This process includes integration for NFV TOR switch and the Datacenter core switch or router.

The following steps are performed in the manual switch configuration process.

  1. Loopback Interface configuration

  2. IP interface configuration which will connect to Transport Network

  3. Routing protocol configuration

  4. VxLAN tunnel configuration

  5. Addition for VxLAN tunnel to VSI.

Configuration example for underlay network

The following table shows the IP addresses and interface details for connectivity.

Table 18: IP addresses and interface details - switch 1
Starter kit ToR Switch 5950 Customer Tor Switch
Loopback Interface Lo 0 10.10.10.10/32 Loopback interface Lo 0 5.5.5.5/32
Vlan interface Vlan 100 192.168.1.2/30 vlan interface Vlan 100 192.168.1.1/30
Connected Interface Bridge-aggregation 50 Connected Interface Bridge-aggregation 51
Table 19: IP addresses and interface details - switch 2
Starter kit ToR Switch 5950 Customer Tor Switch
Loopback Interface Lo 0 20.20.20.20/32 Loopback interface Lo 0 5.5.5.5/32
Vlan interface Vlan 101 192.168.2.2/30 vlan interface Vlan 101 192.168.2.1/30
Connected Interface Bridge-aggregation 50 Connected Interface Bridge-aggregation 52
Assign IP addresses to interfaces, as shown in the table. OSPF is used as the routing protocol in this design. This can be replaced by other routing protocols such as BGP or IS-IS if desired.

Starter kit 5950 switch configuration

Assign an IP address to Loopback 0 and bridge-aggregation 50, which is already configured through automaton script. The IP address is used as the source IP address of the VxLAN tunnels to compute the expansion kit.
interface loopback 0
ip address 10.10.10.10 255.255.255.255
quit
vlan 100
description “Tansport Vlan”
quit
interface vlan 100
ip address 192.168.1.2 255.255.255.252
quit

ospf 1
default-route advertise
area 0
network 10.10.10.10 0.0.0.0
network 192.168.1.0 0.0.0.3

Expansion kit 5950 switch configuration

Assign an IP address to Loopback 0 and bridge-aggregation 50, which is already configured through automaton script. The IP address is used as the source IP address of the VxLAN tunnels' Starter Kit.
interface loopback 0
ip address 20.20.20.20 255.255.255.255
quit
vlan 101
description “Tansport Vlan”
quit
interface vlan 101
ip address 192.168.2.2 255.255.255.252
quit

ospf 1
default-route advertise
area 0
network 20.20.20.20 0.0.0.0
network 192.168.2.0 0.0.0.3

Customer switch configuration

Configure Vlan, Loopback 0, and bridge-aggregation 51 on the customer switch.

interface loopback 0
ip address 5.5.5.5 255.255.255.255

vlan 100
description “Tansport Vlan”
interface vlan 100
ip address 192.168.1.1 255.255.255.252
interface bridge-aggregation 51
Undo port trunk permit vlan 1
port trunk permit vlan port trunk permit vlan 163 164 801 to 900
NOTE:

On the bridge-aggregation 51, OAM, CAN, and provider also have to pass compute kit traffic.

OSPF is used as the routing protocol in this design. This can be replaced by other routing protocols such as BGP or IS-IS if required.

ospf 1
default-route advertise
area 0
network 10.10.10.10 0.0.0.0
network 192.168.1.0 0.0.0.3
network 20.20.20.20 0.0.0.0
network 192.168.2.0 0.0.0.3