Connecting border leaf switches to external network

Prerequisites
  • Connect external devices such as router or switch to border switches.

    For example, port 1/0/56 from both border leaf switches are connected to an external switch on 1/0/31 and 1/0/32 interfaces.

  • Configure IP for the port and eBGP on the Border leaf switches and external devices.

    For example, the following IP addresses are used for point to point configuration between border leaf and external switches.

    10.xx.xx.2/30 Borderleaf-1 1/1/56 10.xx.xx.1/30 External switch port 1/0/31
    10.xx.xx.2/30 Borderleaf-2 1/1/56 10.xx.xx.1/30 External switch port 1/0/32
    AS 65002 AS 65199
  • Attach port 1/0/56 to VRF C10_VPC for border leaf switch.

  • Configure BGP in VRF C10_VPC.

Procedure
  1. Configure the border leaf switches.
    1. Configure IP address for port 1/1/56 on Border Leaf 1 and 2.
      Border Leaf-1:
      interface 1/1/56 
          no shutdown
          mtu 9198
          vrf attach C10_VPC    
          ip mtu 9198
          ip address 10.XX.XX.2/30
      
      Border Leaf-2:
      interface 1/1/56 
          no shutdown
          mtu 9198
          vrf attach C10_VPC    
          ip mtu 9198
          ip address 10.XX.XX.2/30
      
    2. Configure BGP on Border Leaf 1 and 2.
      Border Leaf-1:
      router bgp 65001
               vrf C10_VPC
               neighbor 10.XX.XX.1 remote-as 65199
               neighbor 10.XX.XX.1 timers 30 90
               neighbor 10.XX.XX.1 fall-over bfd
               address-family ipv4 unicast
               neighbor 10.XX.XX.1 activate
      
      Border Leaf-2:
      router bgp 65001
               vrf C10_VPC
               neighbor 10.XX.XX.1 remote-as 65199
               neighbor 10.XX.XX.1 timers 30 90
               neighbor 10.XX.XX.1 fall-over bfd
               address-family ipv4 unicast
               neighbor 10.XX.XX.1 activate
      
  2. Configure BGP on the external switch.
    1. Configure the IP interface on connected interface of the border leaf switch.

      For example, 1/0/31 and 1/0/32 is connected with border leaf switch.

      interface HundredGigE1/0/31
       port link-mode route 
       ip address 10.XX.XX.1 255.255.255.252
      #
      interface HundredGigE1/0/32
       port link-mode route 
       ip address 10.XX.XX.1 255.255.255.252
      #
      
    2. Configure BGP.
      bgp 65199
       router-id 10.XX.XX.1
       peer 10.XX.XX.2 as-number 65001
       peer 10.XX.XX.2 as-number 65001
       #
       address-family ipv4 unicast
        balance 4
        import-route direct
        import-route static
        network 0.0.0.0 0.0.0.0
        peer 10.XX.XX.2 enable
        peer 10.XX.XX.2 enable