VRRP with VSX configuration

VRRP is similar to active gateway in that it is a first hop redundancy protocol that eliminates a single point of failure. One VSX switch acts as a VRRP master and the other switch acts as the VRRP backup. Both VSX switches route the traffic. The active gateway/VRRP configuration must be consistent across the two VSX switches.

Although active gateway and VRRP are no longer globally exclusive in a VSX configuration, active gateway and VRRP are still exclusive on an SVI. A workaround is to configure VRRP on one SVI (SVI A), and configure active-gateway on the other SVI (SVI B).

NOTE:

Active gateway is preferable to VRRP because VRRP traffic is still pushed over the ISL link, resulting in latency.

Sample VRRP configuration

IPV4:

switch(config)# vlan 1-10
switch(config)# router vrrp enable
switch(config)# interface vlan2
switch(config-if-vlan)# ip address 192.168.1.253/16
switch(config-if-vlan)# no shutdown
switch(config-if-vlan)# vrrp 1 address-family ipv4
switch(config-if-vrrp)# address 192.168.1.253 primary
switch(config-if-vrrp)# no shutdown
switch(config-if-vrrp)# exit
switch(config-if-vlan)# exit
switch(config)#

IPV4 and IPV6:

switch(config)# vlan 1-10
switch(config)# router vrrp enable
switch(config)# interface vlan3
switch(config-if-vlan)# ip address 172.3.0.1/16
switch(config-if-vlan)# ipv6 address 2002:3::1/64   
switch(config-if-vlan)# ip ospf 1 area 0.0.0.0   
switch(config-if-vlan)# ipv6 ospfv3 1 area 0.0.0.0  
switch(config-if-vlan)# vrrp 1 address-family ipv4
switch(config-if-vrrp)# address 172.3.0.10 primary
switch(config-if-vrrp)# no shutdown
switch(config-if-vrrp)# exit
switch(config-if-vlan)# vrrp 1 address-family ipv4
switch(config-if-vrrp)# address fe80::3 primary
switch(config-if-vrrp)# no shutdown
switch(config-if-vrrp)# exit
switch(config)#