Enabling VSX synchronization at the global level

The commands in this table are for enabling VSX synchronization at the global level for a feature.

Feature Command for enabling Example

AAA configurations, including user, RADIUS server, and TACACS+ server.

vsx-sync aaa

switch(config)# vsx
switch(config-vsx)# vsx-sync aaa

Access List Log Timer configurations.

vsx-sync acl-log-timer

switch(config)# access-list log timer 30
switch(config)# vsx
switch(config-vsx)# vsx-sync acl-log-timer

ARP security configurations. 1

vsx-sync arp-security

primary_sw(config)# vsx
primary_sw(config-vsx)# vsx-sync arp-security
primary_sw(config-vsx)# vsx-sync mclag-interfaces

BFD configurations.

vsx-sync bfd-global

switch(config)# bfd detect-multiplier 1
switch(config)# bfd min-transmit-interval 1000
switch(config)# bfd min-receive-interval 1000
switch(config)# bfd echo-src-ip-address 2.2.2.2
switch(config)# bfd min-echo-receive-interval 1000
switch(config)# vsx
switch(config-vsx)# vsx-sync bfd-global

BGP configurations.

vsx-sync bgp

switch(config)#  ip aspath-list list1 seq 10 permit 10
switch(config)# ip community-list expanded com1 seq 10 permit 10
switch(config)# ip extcommunity-list standard ext1 seq 10 permit rt 10:4
switch(config)# ip prefix-list pref1 seq 10 permit any
switch(config)# route-map rm1 permit
switch(config-route-map-rm1-10)#  match ip next-hop 1.1.1.1
switch(config)#  router bgp 100
switch(config-bgp)# bgp router-id 1.1.1.1
switch(config-bgp)# neighbor 12.1.1.1 remote-as 1
switch(config-bgp)# address-family ipv4 unicast
switch(config-bgp-ipv4-uc)# neighbor 12.1.1.1 activate
switch(config)# vsx
switch(config-vsx)# vsx-sync bgp

CoPP policy configurations.

vsx-sync copp-policy

switch(config)# vsx
switch(config-vsx)# vsx-sync copp-policy

DCBx configurations (8325 series switches).

vsx-sync dcb-global

switch(config)# lldp dcbx
switch(config)# dcbx application iscsi priority 7
switch(config)# vsx
switch(config-vsx)# vsx-sync dcb-global

DHCPv4 and DCHPv6 relay configurations.

vsx-sync dhcp-relay

switch(config)# interface 1/1/1
switch(config-if)# ip helper-address 192.168.10.1
switch(config-if)# ip helper-address 192.168.20.1
switch(config)# interface 1/1/2
switch(config-if)# ip helper-address 192.168.30.1
switch(config)# dhcp-relay option 82
switch(config)# vsx
switch(config-vsx)# vsx-sync dhcp-relay

DHCPv4 server configurations, including external storage configurations.

vsx-sync dhcp-server

switch(config)# dhcp-server external-storage dhcp-dbs file dhcpv4_lease_file delay 600
switch(config)# dhcp-server vrf default
switch(config-dhcp-server)# pool test
switch(config-dhcp-server-pool)# range 10.0.0.20 10.0.0.30
switch(config-dhcp-server-pool)# default-router 10.0.0.1 10.0.0.10
switch(config-dhcp-server-pool)# static-bind ip 10.0.0.1 mac 24:be:05:24:75:73
switch(config)# vsx
switch(config-vsx)# vsx-sync dhcp-server

DHCPv6 server configurations, including external storage configurations.

vsx-sync dhcpv6-server

switch(config)# dhcpv6-server external-storage dhcpv6-dbs file dhcpv6_lease_file delay 600
switch(config)# dhcp-server vrf default
switch(config-dhcp-server)# pool test
switch(config-dhcpv6-server-pool)# range 2001::1 2001::10 prefix-len 64
switch(config-dhcpv6-server-pool)# option 22 ipv6 2001::12
switch(config-dhcpv6-server-pool)# static-bind ipv6 2001::11 client-id 1:0:a0:24:ab:fb:9c
switch(config)# vsx
switch(config-vsx)# vsx-sync dhcpv6-server

DNS configurations.

vsx-sync dns

switch(config)# vsx
switch(config-vsx)# vsx-sync dns

EVPN configurations.

vsx-sync evpn

switch(config)# vlan 2
switch(config-vlan-2)# vsx-sync
switch(config)# evpn 
switch(config-evpn)# vlan 2
switch(config-evpn-vlan-2)# rd 5:5
switch(config-evpn-vlan-2)#  route-target export 1:1
switch(config-evpn-vlan-2)#  route-target import 1:1
switch(config)# vsx
switch(config-vsx)# vsx-sync evpn

Global classifier policy configurations.

vsx-sync policy-global

switch(config)# apply policy testPolicy in
switch(config)# vsx
switch(config-vsx)# vsx-sync policy-global

IP ICMP configurations.

vsx-sync icmp-tcp

switch(config)# vsx
switch(config-vsx)# vsx-sync icmp-tcp

LLDP configurations.

vsx-sync lldp

switch(config)#  lldp reinit 6 
switch(config)# vsx
switch(config-vsx)# vsx-sync lldp

Loop protect configurations, such as transmit-interval and re-enable-timer. 1

vsx-sync loop-protect-global

switch(config)# loop-protect transmit-interval 10
switch(config)# loop-protect re-enable-timer 300
switch(config)# vsx
switch(config-vsx)# vsx-sync loop-protect-global

MAC lockout configurations.

vsx-sync mac-lockout

switch(config)# mac-lockout 10:10:10:10:10:10 
switch(config)# vsx
switch(config-vsx)# vsx-sync mac-lockout

ND snooping configurations

vsx-sync nd-snooping

switch(config)# vsx
switch(config-vsx)# vsx-sync nd-snooping

Static neighbor configurations.

vsx-sync neighbor

DUT-1 (config-vsx)# show run in vlan127
interface vlan127
		ip address 137.1.1.1/16
		ipv6 address 7f00::1/64
		arp ipv4 137.1.1.35 mac 00:12:01:00:00:1a
		arp ipv4 137.1.1.70 mac 00:12:01:00:00:3d
		exit
DUT-1(config-vsx)
switch(config)# vsx
switch(config-vsx)# vsx-sync neighbor

OSPF configurations.

vsx-sync ospf

switch(config)# router ospf 1
switch(config-ospf-1)# area 0
switch(config-ospf-1)# area 1 nssa
switch(config-ospf-1)# area 2 stub
switch(config-ospf-1)# redistribute connected route-map map1
switch(config)# router ospfv3 1
switch(config-ospfv3-1)# max-metric router-lsa on-startup
switch(config-ospfv3-1)# bfd all-interfaces 
switch(config-if)# ip ospf 1 area 0
switch(config-if)# ip ospf hello-interval 33
switch(config-if)# ipv6 ospfv3 1 area 0
switch(config-if)#  ipv6 ospfv3 dead-interval 55
switch(config)# vsx
switch(config-vsx)# vsx-sync ospf

Route map configurations.

vsx-sync route-map
switch(config)#  ip aspath-list list1 seq 10 permit 10
switch(config)# ip community-list expanded com1 seq 10 permit 10
switch(config)# ip extcommunity-list standard ext1 seq 10 permit rt 10:4
switch(config)# ip prefix-list pref1 seq 10 permit any
switch(config)# route-map rm1 permit
switch(config-route-map-rm1-10)# match ip next-hop 1.1.1.1
switch(config)# vsx
switch(config-vsx)# vsx-sync route-map

QoS Configurations, such as CoS map, DSCP map, and trust policy. 2

vsx-sync qos-global

switch(config)# vsx
switch(config-vsx)# vsx-sync qos-global

sFlow configurations.

vsx-sync sflow

switch(config)# vsx
switch(config-vsx)# vsx-sync sflow

sFlow global configurations.

vsx-sync sflow-global

switch(config)# sflow collector 1.1.1.1 
switch(config)# vsx
switch(config-vsx)# vsx-sync sflow-global

SNMP configurations.

vsx-sync snmp

switch(config)# vsx
switch(config-vsx)# vsx-sync snmp

SSH configurations.

vsx-sync ssh

switch(config)# vsx
switch(config-vsx)# vsx-sync ssh

Static routes.

vsx-sync static-routes

switch(config)# vsx
switch(config-vsx)# vsx-sync static-routes

STP configurations.1

vsx-sync stp-global

switch(config)# spanning-tree config-name abc
switch(config)# spanning-tree config-revision 1
switch(config)# vsx
switch(config-vsx)# vsx-sync stp-global

Time-related configurations, including NTP and time zone configurations.

vsx-sync time

switch(config)# vsx
switch(config-vsx)# vsx-sync time

UDP forwarder configurations.

vsx-sync upd-forwarder

switch(config)# vsx
switch(config-vsx)# vsx-sync upd-forwarder

VRF configurations

vsx-sync vrf

switch(config)# vsx
switch(config-vsx)# vsx-sync vrf
VSX configurations:
  • ISL:

    • Dead interval.

    • Hello interval.

    • Hold time.

    • Peer detect interval.

  • Keepalive:

    • Dead interval.

    • Hello interval.

    • UDP port number.

  • The delay time setting for the link-up delay timer.

  • The split recovery setting.

  • The system MAC address.

vsx-sync vsx-global

switch(config)# vsx
switch(config-vsx)# inter-switch-link dead-interval 15
switch(config-vsx)# inter-switch-link hello-interval 2
switch(config-vsx)# inter-switch-link hold-time 1
switch(config-vsx)# vsx-sync vsx-global

VSX LAG interfaces.

vsx-sync mclag-interfaces

switch(config)# vsx
switch(config-vsx)# vsx-sync mclag-interfaces

VRRP configurations.

vsx-sync vrrp
switch(config)# router vrrp enable
switch(config-if)# vrrp 1 address-family ipv4
switch(config-if-vrrp)# address 1.1.1.100 primary
switch(config-if-vrrp)# timers advertise 1000
switch(config-if-vrrp)# no shutdown
switch(config-if)# vrr 1 address-family ipv6
switch(config)# vsx
switch(config-vsx)# vsx-sync vrrp
1

To enable VSX synchronization at the context level for this feature, enter the

vsx-sync mclag-interfaces

command at the context level.

2

To enable VSX synchronization at the context level for this feature, enter the

vsx-sync qos

command at the context level.