PIM-SM configuration example

The following is a sample topology diagram for a PIM-SM configuration.


  Multicast     +-----------+                  +-----------+
  Source        |           |1/1/1         1/1/1           |1/1/2
            1/1/2 Router1   +------------------+ Router2   +-------------+
       +--------|           |CBSR              |           |        IGMP
                |           |CRP               |           |       Clients
                +-----------+                  +-----------+

In this topology, the multicast source is connected to Router1 and Clients are connected to Router2.

Router1 and Router2 are directly connected so you can verify the neighborship using the show ip pim neighbor command.

Secondly Router1 interface 1/1/1 is the BSR candidate and RP candidate in this domain. This information needs to be propagated across the network and needs to be consistent on all routers in the topology. To verify this, use the show ip pim rp-set command for group mapping information and the show ip pim bsr command for elected BSR information. If they show inconsistent information, you could see possible multicast outages.

If the joins are seen by the routers before the streams can flow, both routes will display those requests in the show ip pim pending command output.

Once the multicast source streams start to flow, each router in the path will add multicast router (mroute) entries, which can be verified using the show ip mroute command.

The output of the following show running-config command shows an example of PIM-SM configuration for IPv4.

switch# show running-config
Current configuration:
!
!
!
!
!
Router1
---------------

router ospf 1
    redistribute connected
    area 0.0.0.0
router pim
    enable
    bsr-candidate source-ip-interface 1/1/1
    rp-candidate source-ip-interface 1/1/1
    rp-candidate group-prefix 224.0.0.0/4
interface 1/1/1
    ip address 10.10.10.1/24
    ip ospf 1 area 0.0.0.0
    ip pim-sparse enable
interface 1/1/2 
    ip address 20.20.20.1/24
    ip pim-sparse enable


Router2
---------------
router ospf 1
    redistribute connected
    area 0.0.0.0
router pim
    enable
interface 1/1/1
    ip address 10.10.10.2/24
    ip ospf 1 area 0.0.0.0
    ip pim-sparse enable
interface 1/1/2 
    ip address 30.30.30.1/24
    ip pim-sparse enable
    ip igmp enable

The output of the following show running-config command shows an example of PIM-SM configuration for IPv6.

switch# show running-config
Current configuration:
!
!
!
!
!
Router1
---------------
router ospfv3 1
redistribute connected
area 0.0.0.0

router pim6
bsr-candidate source-ip-interface loopback1
rp-candidate source-ip-interface loopback1
rp-candidate group-prefix ff00::/8
enable


interface loopback 1
ipv6 address 1000::1000/64
ipv6 ospfv3 1 area 0.0.0.0
ipv6 pim6-sparse enable

interface 1/1/1
ipv6 address 2000::1/64
ipv6 ospfv3 1 area 0.0.0.0
ipv6 pim6-sparse enable

interface 1/1/2
ipv6 address 4000::1/64
ipv6 pim6-sparse enable

Router2
---------------
router ospfv3 1
redistribute connected
area 0.0.0.0

router pim6
enable

interface 1/1/1
ipv6 address 2000::2/64
ipv6 ospfv3 1 area 0.0.0.0
ipv6 pim6-sparse enable

interface 1/1/2
ipv6 address 5000::1/64
ipv6 pim-sparse enable
ipv6 mld enable