Comparing VLAN commands on PVOS, Comware, and ArubaOS-CX

The following examples compare the commands needed to implement typical VLAN configurations on different HPE products.

Scenario 1: Inter-switch link with all traffic tagged.

ArubaOS-CX

interface 1/1/1
  no routing
vlan trunk native 1
  vlan trunk allowed 10,30,50

A native VLAN must be defined on the switch. By default, this is VLAN 1. Since only VLANs 10, 30 and 50 are allowed on the trunk, all untagged traffic is dropped.

PVOS

interface A1
  tagged vlan 10,30,50
  no untagged vlan 1

Comware

Interface G1/0/1
  port link type trunk
  port trunk permit vlan 10,30,50
  port trunk pvid vlan 1 

PVID 1 is the default setting.

Scenario 2: Inter-switch link with all traffic tagged, except for untagged traffic on a specific VLAN.

ArubaOS-CX

interface 1/1/1
  no routing
  vlan trunk native 10 tag
  vlan trunk allowed 10,30,50

Same as scenario 1, but allows untagged traffic on VLAN 10 as well.

PVOS

Not directly supported in PVOS. Scenario 1 is a workaround if there is no need to support untagged traffic.

Comware

Not directly supported in Comware. A possible workaround is:

interface g1/0/1
  port link-mode bridge
  port link-type hybrid
  port hybrid protocol-vlan vlan 10
  port hybrid vlan 10 tagged
  port hybrid vlan 30 tagged
  port hybrid vlan 50 tagged

Scenario 3: Inter-switch link with all traffic tagged or untagged.

ArubaOS-CX

interface 1/1/1
  no routing 
  vlan trunk native 5
  vlan trunk allowed 5, 10,30,50

VLAN 5 must be allowed on the trunk so that untagged traffic is not dropped.

PVOS

interface A1
  untagged vlan 5
  no tagged vlan 10,30,50

Comware

interface G1/0/1
  Port link-mode bridge
  port link-type trunk
  port trunk pvid vlan 5
  port trunk permit vlan 5,10,30,50

link-mode is only needed on later Comware 7 devices. 5930 is port link-mode route by default. 5900 is bridge by default.

Scenario 4: Edge device/access port.

ArubaOS-CX

  interface 1/1/1
  no routing
  vlan access 5

PVOS

interface A1
  untagged vlan 5

Comware

interface G1/0/0
  port link-mode bridge
  port access vlan 5