Viewing the startup configuration of interfaces

To view the startup configuration of interfaces, do one of the following:

  • Use the show config command to view the startup configuration of all interfaces.

  • Use the show config interface port-listcommand to view the startup configuration of the specified port interfaces.

  • Use the show config interface loopback <0-7>command to view the startup configuration of the specified VLAN interfaces.

Examples

The following example shows startup configuration output.
switch(config)# show config

Startup configuration:

; J8698A Configuration Editor; Created on release #K.14.54C
; Ver #02:0b:ef:e6
hostname "switch"
module 1 type J9309A
module 3 type J8702A
module 6 type J8702A
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A4,C1-C9,C15-C24,F1-F24
   ip address dhcp-bootp
   no untagged C10-C14
   exit
vlan 5
   name "VLAN5"
   untagged C10-C14
   ip address 5.1.1.1 255.255.255.128
   exit
interface loopback 5
   ip address 7.1.1.1
   exit
interface loopback 7
   ip address 12.1.1.1
   exit
snmp-server community "public" unrestricted

Following is an example of the startup config output for a selected VLAN.

switch(vlan-5)# show config vlan 5

Startup configuration:

vlan 5
   name "VLAN5"
   untagged C10-C14
   ip address 5.1.1.1 255.255.255.128
   exit

The following shows an example of the startup config output for a range of interfaces for a specific VLAN.

Startup config output for a range of interfaces for a specific VLAN
switch(vlan-5)# show config interface C10-C13

Startup configuration:

interface C10
   untagged vlan 5
   exit
interface C11
   untagged vlan 5
   exit
interface C12
   untagged vlan 5
   exit
interface C13
   untagged vlan 5
   exit