Viewing the running configuration of interfaces

To view the running configuration of interfaces, do one of the following:

Procedure
  1. Use the show running-config [structured]command to view the running configuration of all interfaces. Include the structured option to group the information in a logical manner.
  2. Use the show running-config interface port-listcommand to view the running configuration of the specified port interfaces. Include the structuredoption to group the information in a logical manner.
  3. Use the show running-config interface loopback <0-7> command to view the running configuration of the specified loopback interfaces. Include the structuredoption to group the information in a logical manner.
  4. Use the show running-config interface vlan <vlan-id-list>

    command to view the running configuration of the specified VLAN interfaces. Include the structured option to group the information in a logical manner.

Examples

The following example shows Running configuration output in preview mode.
switch(config)# preview-mode 
ATTENTION: You are entering preview mode on this product. This mode, the 
commands, features and functionality specific to this mode, and all output
from this mode are Hewlett Packard Enterprise Confidential and Proprietary.
You may use this mode at your own risk. Any defects or issues encountered  
in this mode will be addressed per Hewlett Packard Enterprise's discretion.
Continue (y/n)? y                                                           
(Prev-mode)switch(config)# show running-config

Running configuration:

; JL075A Configuration Editor; Created on release #KB.xx.xx.0000x
; Ver #0c:01.7c.59.f4.7b.ff.ff.fc.ff.ff.3f.ef:

hostname "Aruba-3810M-16SFPP-2s"
module 1 type jl075x
module 2 type jl075y
module 3 type jl075z
snmp-server community "public" unrestricted
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-16
   ip address dhcp-bootp
   exit
preview-mode
The following example shows Running configuration output for interfaces A2 - A4
switch(eth-A2-A4)# show running-config

Running configuration:

; J8698A Configuration Editor; Created on release #K.xx.xx.000x
; Ver #02:0b:ef:e6
hostname "switch"
interface A2
   disable
   name "test1"
   flow-control
   broadcast-limit 80
   speed-duplex 100-full
   unknown-vlans Block 
   qos priority 4 
   lacp Passive
   gvrp join-timer 30
   gvrp leave-timer 60
   gvrp leaveall-timer 700
exit
interface A3
   disable name "test1"
   flow-control
   broadcast-limit 80
   speed-duplex 100-full
   unknown-vlans Block
   qos priority 4
   lacp Passive
   gvrp join-timer 30
   gvrp leave-timer 60
   gvrp leaveall-timer 700
exit
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A4,C1-C24,F1-F4
   ip address dhcp-bootp
   exit
interface A2
   dhcp-snooping trust
   bandwidth-min output 20 10 10 10 20 10 10 10
   rate-limit bcast in percent 75
   ipv6 access-group "check" in
   exit
interface A3
   dhcp-snooping trust
   bandwidth-min output 20 10 10 10 20 10 10 10
   rate-limit bcast in percent 75
   ipv6 access-group "check" in
   exit

The following example shows an example of the running config for a range of interfaces. The configuration information for interfaces A2 and A3 is now displayed together.

switch(config)# show running-config interface A2-A3

Running configuration:

interface A2
   disable
   name "test1"
   flow-control
   broadcast-limit 80
   speed-duplex 100-full
   unknown-vlans block
   qos priority 4
   gvrp join-timer 30 leave-timer 60 leaveall-timer 700
   dhcp-snooping trust
   lacp passive
   bandwidth-min output 20 10 10 10 20 10 10 10
   rate-limit bcast in percent 75
   ipv6 access-group "check" in
   untagged vlan 1
   exit
interface A3
   disable
   name "test1"
   flow-control
   broadcast-limit 80
   speed-duplex 100-full
   unknown-vlans block
   qos priority 4
   gvrp join-timer 30 leave-timer 60 leaveall-timer 700
   dhcp-snooping trust
   lacp passive
   bandwidth-min output 20 10 10 10 20 10 10 10
   rate-limit bcast in percent 75
   ipv6 access-group "check" in
   untagged vlan 1
   exit

The following example shows an example of the running config file for a range of interfaces after some configuration changes have been made.

switch(config)# no stack
switch(config)# mesh 2-3
Command will take effect after saving configuration and reboot.

switch(config)# write memory
switch(config)# reload

switch# show running-config interface 2-3

Running configuration:

interface 2
   untagged vlan 1
   mesh
   exit
interface 3
   flow-control
   untagged vlan 1
   mesh
   exit

The following example is an example of the running config output showing VLAN information.

switch(config)# show running-config

Running configuration:
; J8698A Configuration Editor; Created on release #K.xx.xx.000x
; Ver #02:0b:ef:e6
hostname "switch"
module 1 type J9309A
module 3 type J8702A
module 6 type J8702A
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A4,C1-C24,F1-F24
   ip address dhcp-bootp
   exit
vlan 2
   name "test-vlan-2"
   ip helper-address 4.1.1.1
   ip helper-address 5.1.1.1
   ip address 1.1.1.1 255.255.255.0
   ipv6 address 2001::/64 anycast
   ipv6 enable
   exit
vlan 3
   name "VLAN3"
   ip helper-address 7.1.1.1
   ip forward-protocol udp 7.1.1.1 snmp
   ip forward-protocol udp 11.1.1.2 dns
   no ip address
   exit
vlan 4
   name "VLAN4"
   ip address 5.1.1.1 255.255.255.0
   ip bootp-gateway 5.1.1.1
   exit
logging 10.0.102.90
logging system-module ospf
ip route 5.1.1.0 255.255.255.0 vlan 4 distance 3

In the following example, the configuration information for VLAN 4 is now displayed in one place.

switch(config)# show running-config vlan 3-4

Running configuration:

vlan 3
   name "VLAN3"
   ip helper-address 7.1.1.1
   ip forward-protocol udp 7.1.1.1 snmp
   ip forward-protocol udp 11.1.1.2 dns
   no ip address
   exit
vlan 4
   name "VLAN4"
   ip address 5.1.1.1 255.255.255.0
   ip bootp-gateway 5.1.1.1
   ip route 5.1.1.0 255.255.255.0 distance 3
   exit

Below is an example of the running config for a range of VLANs after configuration changes have been made to selected VLANs.

switch(config)# dhcp-snooping
switch(config)# vlan 14
switch(vlan-14)# exit
switch(config)# vlan 15
switch(vlan-15)# exit
switch(config)# vlan 23
switch(vlan-23)# exit
switch(config)# dhcp-snooping vlan 14-15
switch(config)# static-mac 00:11:22:33:44:55 vlan 23 interface A3
switch(config)# spanning-tree instance 2 vlan 15

switch(config)# show running-config vlan 14-15

Running configuration:

vlan 14
   name "VLAN14"
   no ip address
   dhcp-snooping
   exit
vlan 15
   name "VLAN15"
   no ip address
   dhcp-snooping
   spanning-tree instance 2
   exit