Configuration procedure

Procedure
  1. Configure IP addresses for interfaces (omitted.)
  2. Configure BGP connections.
  3. # Configure Switch A.
    switch(config)# router bgp 100
    switch(bgp)# bgp router-id 1.1.1.1
    switch(bgp)# neighbor 192.1.1.2 remote-as 200
    
    
  4. # Add network 1.0.0.0/8 to the BGP routing table.
    switch(bgp)# network 1.0.0.0
    switch(bgp)# exit
    
  5. # Configure Switch B.
    switch(config)# router bgp 200
    switch(bgp)# bgp router-id 2.2.2.2
    switch(bgp)# neighbor 192.1.1.1 remote-as 100
    switch(bgp)# neighbor 193.1.1.1 remote-as 200
    switch(bgp)# neighbor 193.1.1.1 next-hop-self
    switch(bgp)# exit
    
    
  6. # Configure Switch C.
    switch(config)# router bgp 200
    switch(bgp)# bgp router-id 3.3.3.3
    switch(bgp)# neighbor 193.1.1.2 remote-as 200
    switch(bgp)# neighbor 194.1.1.2 remote-as 200
    switch(bgp)# exit
    
    
  7. # Configure Switch D.
    switch(config)# router bgp 200
    switch(bgp)# bgp router-id 4.4.4.4
    switch(bgp)# neighbor 194.1.1.1 remote-as 200
    switch(bgp)# exit
    
    
  8. Configure the route reflector.
  9. # Configure Switch C.
    switch(config)# router bgp 200
    switch(bgp)# neighbor 193.1.1.2 route-reflector-client
    switch(bgp)# neighbor 194.1.1.2 route-reflector-client
    switch(bgp)# exit
    
    
  10. Verify the above configuration.
  11. # Display the BGP routing table on Switch B.
    switch(config)# show ip bgp
    
    Local AS : 200
    Local Router-id : 200.1.2.2
    
    BGP Table Version  : 1
    Status codes: * - valid, > - best, i - internal, e - external, s - stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
    Network          Nexthop     Metric LocalPref Weight  AsPath
    ------------------------------------------------------------
    *>i 1.0.0.0/24   200.1.3.1       0              0     100i
    
    
  12. # Display the BGP routing table on Switch D.
    switch(config)# show ip bgp
    
    Local AS : 200
    Local Router-id : 200.1.2.2
    
    BGP Table Version  : 1
    Status codes: * - valid, > - best, i - internal, e - external, s - stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
    Network        Nexthop     Metric LocalPref Weight AsPath
    -------------------------------------------------------
    *>e 1.0.0.0/24 200.1.3.1        0           100    100i
    
    
  13. Switch D learned route 1.0.0.0/8 from Switch C.