Configuration procedure

Procedure
  1. Configure Switch A.
  2. # Configure IP addresses for interfaces (omitted.)
  3. # Configure the eBGP connection.
    switch(config)# router bgp 65008
    switch(bgp)# bgp router-id 1.1.1.1
    
    
  4. # Configure BGP GR stalepath-timeout (optional.)
    switch(bgp)# bgp graceful-restart stalepath-time 360
    switch(bgp)# neighbor 200.1.1.1 remote-as 65009
    
    
  5. # Add network 8.0.0.0/8 to the BGP routing table.
    switch(bgp)# network 8.0.0.0/8
    
    
  6. # Enable GR for BGP Peer.
    switch(bgp)# neighbor 200.1.1.1 graceful-restart
    
    
  7. Configure Switch B.
  8. # Configure IP addresses for interfaces (omitted.)
  9. # Configure the eBGP connection.
    switch(bgp)# router bgp 65009
    
    
  10. # Configure BGP GR restart-time and stalepath-timeout (Optional.)
    switch(bgp)# bgp graceful-restart restart-time 120
    stalepath-time 360
    switch(bgp)# bgp router-id 2.2.2.2
    switch(bgp)# neighbor 200.1.1.2 remote-as 65008
    
    
  11. # Configure the iBGP connection.
    switch(bgp)# neighbor 9.1.1.2 remote-as 65009
    
    
  12. # Configure BGP to redistribute direct routes.
    switch(bgp)# redistribute connected
    
    
  13. # Enable GR capability for BGP Peers.
    switch(bgp)# neighbor 200.1.1.2 graceful-restart
    switch(bgp)# neighbor 9.1.1.2 graceful-restart
    
    
  14. # Configure BGP for non-stop forwarding
    switch(bgp)# non-stop
    
    
  15. Configure Switch C.
  16. # Configure IP addresses for interfaces (omitted.)
  17. # Configure the iBGP connection.
    switch(config)# router bgp 65009
    switch(bgp)# bgp router-id 3.3.3.3
    switch(bgp)# neighbor 9.1.1.1 remote-as 65009
    
    
  18. # Configure BGP to redistribute direct routes.
    switch(bgp)# redistribute connected
    
    
  19. BGP Configuration Example
  20. # Enable GR for BGP Peer.
    switch(bgp)# neighbor 9.1.1.1 graceful-restart